Jump to content
Sign in to follow this  
Kisle

UGFX + ChibiOS -RT KERNEL >= 5

Recommended Posts

Hi There,

I know that there are quite a handful of other topics out there that talk about the same Problem. But somehow, I could not find a solution for me yet.

For a few days I have been trying to get ugfx together with chibios and the STM32F429i to work. But so far nothing worked out for me. I found some older projects that actually worked with older ChibiOS Versions, but for the newer Version i never got it to actually display something.

I use, ChibiOS-version 18.2.1 and I would like to use the up to date ugfx Version that i pulled from there: https://git.ugfx.io/uGFX/uGFX
Then I basically tried to modify this example https://community.ugfx.io/files/file/22-stm32f429i-discovery-with-chibios-using-chibistudio/ to get it to work with the newer ugfx version. It would be nice if someone could share a running minimalistic setup... Otherwise, this is the compiler errors I get when compiling:

In file included from ../ugfx/boards/base/STM32F429i-Discovery/chibios/stm32f429i_discovery_sdram.c:4:0:
../ugfx/boards/base/STM32F429i-Discovery/chibios/stm32f429i_discovery_sdram.h:89:25: error: unknown type name 'gU32'
 void  SDRAM_WriteBuffer(gU32* pBuffer, gU32 uwWriteAddress, gU32 uwBufferSize);

and before that I also receive some warnings:

In file included from ../ugfx/src/gtrans/../../src/gfx.h:148:0,
                 from ../ugfx/src/gtrans/../../gfx.h:7,
                 from ../ugfx/src/gtrans/gtrans.c:9:
../ugfx/src/gtrans/../../src/gdisp/gdisp_rules.h:69:7: warning: "GDISP_HARDWARE_PIXELREAD" is not defined, evaluates to 0 [-Wundef]
   #if GDISP_HARDWARE_PIXELREAD


Thanks for your help

Greetings
Kisle

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...