Jump to content
Joel Bodenmann

uGFX-Studio v0.20 - Beta

Recommended Posts

v0.20.10 is now available for download. Changelog:

  • Fixing issue with widgets not having assigned their proper parent container in the generated code
  • Fixing issue with GHandle declaration in the generated code
  • Adding support for widget tags
  • Internal improvements

Share this post


Link to post
Share on other sites

Dear Joel!  I try to find lightweight GUI for small microcontrollers with GUI designer, but up to now not foound it.

I try to use uGUI (small and simple), but without designer. I write beta GUI designer by myself - it is big and hard job!

As I see you work on it to - so, can I test uGFX studio?

Thanks in advance - SLeo

Share this post


Link to post
Share on other sites

Hello,

This is a tiny bugs report:

1 / GDISP_NEED_CONVEX_POLYGON is missing when you use Arrow button (same problem for rounded)

2 / When you use a font or image somewhere and you remove it, application can crash if you goes back to the page where the image was used

3 / When save crash, it kills your project (unable to reopen it). Please do an automatic backup before saving and remove it if save was a success

4 / When you try to generate, it's often locked and you have to retry a second time

5 / if you use an image with a name starting with a number, it creates wrong C variables

Thank you.

Share this post


Link to post
Share on other sites

7 / Background image display is slow on a 2 Ghz arm but i checked cache for image

When i search images look loaded in guiResourcesManagerInit but they are also as binary buffer linked.

Could you move "#ifdef ROMFS_DIRENTRY_HEAD" at the top of the include to speed up build when ROMFS_DIRENTRY_HEAD is not def (buffer looks useless in this case)

 

 

Share this post


Link to post
Share on other sites

Hello.

I'm trying to add image(gif format) size of 480x272. At the first, the maximum in the second picture, the program crashes.

Also, I have a question.

How to add fonts included in the library to the project.

Best regards.

 

Share this post


Link to post
Share on other sites

I have big project (~300k project file, with number of pages, buttons, containers labels and so on) made in old Studio. Now Studio 0.15 tells me that test version was expired, Studio 0.20 cannot load my project file, because its format was changed.

Maybe, there is a way to run version 0.15?

In ver 0.20 I placed label, set text in russian, but I cannot see russian chars inside a label. I have changed font (got it from old project) - nothing was changed.. what I'm doing wrong? Got crashes while trying to add/change fonts.

How to set Image to PushButton?

Edited by king2

Share this post


Link to post
Share on other sites

I will try to write posts about problems I met with Studio 0.20. I'm using Windows 10 x64.

1. https://fonts.ugfx.io, mentioned at first page, doesnt works. Use http instead. I think it would be nice to change URL in the post.

2. Adding new fonts according to manual from same post, doesn't works for me. I found that I must to select 'Label' first, then choose file and write name. No effect without selecting 'Label' first.

3. Selecting font files (and I picture files and other files as well) almost always points me to root of my PC disks. I think it will be nice to remember last place where I have picked the file and point it to same place when Browse will be clicked next time.

4. I can select Image as rendering routine for PushButton, but I found no way to assign image for button.

That's all for now, because I cannot make my interface without image pushbuttons.

Share this post


Link to post
Share on other sites
On 1/6/2018 at 03:38, king2 said:

In ver 0.20 I placed label, set text in russian, but I cannot see russian chars inside a label. I have changed font (got it from old project) - nothing was changed.. what I'm doing wrong?

I'll have to check on that - It worked once, once many updates ago... I'll have a look at that!

 

On 1/6/2018 at 03:38, king2 said:

Got crashes while trying to add/change fonts.

Can you reproduce them?

 

On 1/6/2018 at 03:38, king2 said:

How to set Image to PushButton?

For some reason the custom parameter field that is used to assign the image is no longer showing in the latest release. We'll fix that!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×