Jump to content
Delbandung

New User ugfx Set Up

Recommended Posts

Dear Mr. Joel Bodenmann (ugfx Guru),

First of all I would like to thanks for the software for test.

I already download ugfx 0.14 but I have problem when tried to test PREVIEW and got message as below :

C:/ugfx_studio_0.14_windows/ugfx_library/tools/gmake_scripts/compiler_gcc.mk:34: C:/ugfx_studio_0.14_windows/ugfx/TestProject/xxx/preview/C:/ugfx_studio_0.14_windows/ugfx_library/tools/gmake_scripts/cpu_x86.mk: Invalid argument

 

0 [main] sh 3856 sync_with_child: child 3740(0x154) died before initialization with status code 0xC0000142

 

76 [main] sh 3856 sync_with_child: *** child state waiting for longjmp

 

/usr/bin/sh: fork: Resource temporarily unavailable

 

make: *** No rule to make target `C:/ugfx_studio_0.14_windows/ugfx/TestProject/xxx/preview/C:/ugfx_studio_0.14_windows/ugfx_library/tools/gmake_scripts/cpu_x86.mk'. Stop.

 

 

Then I tried to solve the problem wich follow the First Compile tutorial, but I did not understand the First Compile procedures ... could you please list up the procedures to do the set up First Compile procedures ... Thanks

Del Bandung

delbandung@gmail.com

Share this post


Link to post
Share on other sites

Hello and welcome to the community!

Can you please tell us which operating system you are using? The µGFX-Studio Windows version will only work properly on 64-Bit systems. The compiler that are part of the download to build the preview are will also only work on a 64-Bit Windows System.

We are happy to improve our documentation. Can you please tell us which part of the article "Your first compile - Windows" you didn't understand?

Share this post


Link to post
Share on other sites

I really do not understand to set up the particular things below :

Setting Your Environment

Open a command prompt and set the path for the window to include the cygwin utilities.

PATH=C:\cygwin\bin;%PATH%

or

PATH=C:\cygwin64\bin;%PATH%

for a 64-Bit version of cygwin.

The First Build

Using the command prompt with the correctly set path (as above), change directory to your new project folder (TestProject). Type "make" to build your first demo. To run it after building:

.build/TestProject.exe

You can also use "make clean" to clean up all the object files etc that were created.

TQ

Share this post


Link to post
Share on other sites

Dear Guru,

I have already passed the environment set up ... ok

but how to set up The First Build ? I mean where i should set the  .build/TestProject.exe

I new in linux Guru ... please help me ...

Tq

Del

Share this post


Link to post
Share on other sites

Sorry for the late reply. We have been out of office over Easter.

We will rewrite the wiki article a bit to make things more clear. However, this might take a day or two until we get to it.

The .build/TestProject.exe is a file generated by the compiler.
When your setup is complete all you have to do is execute the make command in a terminal in the directory that contains the Makefile for compiling a project.

Share this post


Link to post
Share on other sites

Dear GURU ...

Thnks for the reply. I just put one or two of the widgets but when run the PREVIEW ... still got the same problem (I put 3 widgets push button only )

Setting up environment...

Generating makefile...

Generating user colors...

Generating styles...

Generating code...

Generating configuration...

Generating resource files...

Generating main function files...

Compiling program...

Compiling failed:

exit code = 2

exit status = 0

 

and the detail as below :

.

 

Compiling gui.c

 

make: i686-pc-mingw32-gcc: Command not found

 

C:/ugfx_studio_0.14_windows/ugfx_library/tools/gmake_scripts/compiler_gcc.mk:242: recipe for target '.build/obj/gui.o' failed

 

make: *** [.build/obj/gui.o] Error 127

make: *** Waiting for unfinished jobs....

 

C Compiler Options....

 

i686-pc-mingw32-gcc -c -ggdb -O0 -m32 -fomit-frame-pointer -Wall -Wextra -Wstrict-prototypes -fverbose-asm -ffunction-sections -fdata-sections -fno-common -flto -MMD -MP -MF .build/dep/fakefile.o.d -I. -I/cygdrive/C/ugfx_studio_0.14_windows/ugfx_library -I/cygdrive/C/ugfx_studio_0.14_windows/ugfx_library/3rdparty/tinygl-0.4-ugfx/include -I/cygdrive/C/ugfx_studio_0.14_windows/ugfx_library/drivers/multiple/Win32 -I/cygdrive/C/ugfx_studio_0.14_windows/ugfx_library/drivers/gaudio/Win32 -DGDISP_SCREEN_WIDTH=640 -DGDISP_SCREEN_HEIGHT=480 -DGFX_USE_OS_WIN32=TRUE fakefile.c -o .build/obj/fakefile.o

 

 

Linker Options........

 

i686-pc-mingw32-gcc -m32 -Wl,--gc-sections -lgdi32 -lwinmm .build/obj/fakefile.o -o .build/preview.exe

 

 

Please advice me ... what is the set up problem in this case ... tq

Share this post


Link to post
Share on other sites

This is something that shouldn't happen with the µGFX-Studio 0.14 version for Windows. Can you confirm that you are using that version?
Note that you are not allowed to move the files around. Keep the internal file structure exactly as it is.

Can you please go under Preferences -> Build and make sure that the "Use built-in" checkbox is checked?

Share this post


Link to post
Share on other sites

Dear Guru ...

Thanks for solve my problem ... I think there is some problem of my cursor click which I did not notice before during setting preference as per your video PREVIEW set up ...

result ... OK and good working during run THE PREVIEW .... THANKS a lot ... now I can go throughthe next step of uGFX

Share this post


Link to post
Share on other sites

Dear GURU,

After first problem solved ... then I follow next step like the video of PREVIEW tutorial to run generator code , but I could get the program studio/editor but directly go to the project folder. I think I still do not set up the linux linker correctly ... but I still do not understand yet ... what should I do next guru ? TQ

Share this post


Link to post
Share on other sites

I'm sorry, I really don't understand your question. Can you try to explain again what isn't working?
Note that this has nothing to do with Linux. You are using the Windows version on a Windows operating system. No Linux involved at all.

Share this post


Link to post
Share on other sites

Sorry ... in video tutorial after run the code generator, then we see the windows of code generated succesfully then there are choices OK and OPEN FOLDER , but I can not find the ufgx_gui.c  and gfxconf.h files as like as in video PREVIEW tutorial ... what I have are :

"C:\ugfx_studio_0.14_windows\TestProject\xxx\output\rsc"
"C:\ugfx_studio_0.14_windows\TestProject\xxx\output\colors.h"
"C:\ugfx_studio_0.14_windows\TestProject\xxx\output\gfxconf.h"
"C:\ugfx_studio_0.14_windows\TestProject\xxx\output\gui.c"
"C:\ugfx_studio_0.14_windows\TestProject\xxx\output\gui.h"
"C:\ugfx_studio_0.14_windows\TestProject\xxx\output\main_sample.c"
"C:\ugfx_studio_0.14_windows\TestProject\xxx\output\romfs_files.h"
"C:\ugfx_studio_0.14_windows\TestProject\xxx\output\userfonts.h"
"C:\ugfx_studio_0.14_windows\TestProject\xxx\output\widgetstyles.h"

Edited by Delbandung
wrong type ...

Share this post


Link to post
Share on other sites

The output you are getting is correct. All files that are supposed to be there are there.

We completely reworked the code generator for the 0.13 release. The video was made with a previous version.
The ugfx_gui.c mentioned in the video was split up into different files. You can find the GUI declaration and initialization code in the gui.c file.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...