Jump to content
Shiv.Mahadevappa

Preview Generator

Recommended Posts

Hi,

I'm unable to run "Preview Generator", please see the details bellow.

Setting up environment...

Generating makefile...

Generating user colors...

Generating user styles...

Generating code...

Generating configuration...

Generating resource files...

Generating main function files...

Compiling program...

Process error: Failed to start

Any information regarding above ERROR would be greatly appreciated.

Cheers

Share this post


Link to post
Share on other sites

Hello Shiv and welcome to the community!

Can you please let us know which version of the uGFX-Studio and what operating system you are using?

You might want to click the "Show Details" button to get some more information.

~ Tectu

Share this post


Link to post
Share on other sites

I am unable to use the preview as well on 0.12

Windows 10 x64

 

Setting up environment...
Generating makefile...
Generating user colors...
Generating user styles...
Generating code...
Generating configuration...
Generating resource files...
Generating main function files...
Compiling program...
Compiling failed:
   exit code   = 2
   exit status = 0

 

      0 [main] make 656 D:\Projects\STM32\uGFX\ugfx_studio_0.12_windows\cygwin_toolchain\bin\make.exe: *** fatal error in forked process - fork: can't reserve memory for parent stack 0x600000 - 0x800000, (child has 0x400000 - 0x600000), Win32 error 487

   1035 [main] make 656 cygwin_exception::open_stackdumpfile: Dumping stack trace to make.exe.stackdump

      0 [main] make 10344 fork: child -1 - forked process 656 died unexpectedly, retry 0, exit code 0x100, errno 11

make: D:/Projects/STM32/uGFX/ugfx_studio_0.12_windows/ugfx_library/tools/gmake_scripts/compiler_gcc.mk:346: fork: Resource temporarily unavailable

 170917 [main] make 18536 D:\Projects\STM32\uGFX\ugfx_studio_0.12_windows\cygwin_toolchain\bin\make.exe: *** fatal error in forked process - fork: can't reserve memory for parent stack 0x600000 - 0x800000, (child has 0x400000 - 0x600000), Win32 error 487

 171817 [main] make 18536 cygwin_exception::open_stackdumpfile: Dumping stack trace to make.exe.stackdump

 224659 [main] make 10344 fork: child -1 - forked process 18536 died unexpectedly, retry 0, exit code 0x100, errno 11

make: fork: Resource temporarily unavailable

 

Edited by MobileWill

Share this post


Link to post
Share on other sites

That definitely seems to be a problem related to cygwin, not to the µGFX-Studio. Apparently make doesn't get enough memory to get the job done :P

Anyway, the µGFX-Studio is well tested on Windows 10 x64 and we can't reproduce the problem. I am not sure how to help here.

Share this post


Link to post
Share on other sites

I tried to replicate this on multiple different windows machines, some of which have never seen uGFX before. I tested Windows 7, 8.1 and 10, no problems at all. All of which were 64-Bit versions (we are definitely not going to support 32-bit).

I will keep trying to figure out what the problem is. If somebody has an idea please let us know!

Share this post


Link to post
Share on other sites
34 minutes ago, Joel Bodenmann said:

I tried to replicate this on multiple different windows machines, some of which have never seen uGFX before. I tested Windows 7, 8.1 and 10, no problems at all. All of which were 64-Bit versions (we are definitely not going to support 32-bit).

I will keep trying to figure out what the problem is. If somebody has an idea please let us know!

Which build of Win10 do you have? Do you have the latest? I tried on a VM I have on my laptop and same thing. But all my Win10's are on the latest build. Maybe something broke in the latest build. 

Share this post


Link to post
Share on other sites

I think I made a bit of progress. I install cygwin fresh and copied over the directory to ugfx cygwin directory. Now I get this. So this means make is running instead of failing to even run make.

 

.

C Compiler Options....

i686-pc-mingw32-gcc -c -ggdb -O0 -m32 -fomit-frame-pointer -Wall -Wextra -Wstrict-prototypes -fverbose-asm -ffunction-sections -fdata-sections -fno-common -flto -MMD -MP -MF .build/dep/fakefile.o.d -I. -I/cygdrive/C/ugfx_studio_0.13_windows/ugfx_library -I/cygdrive/C/ugfx_studio_0.13_windows/ugfx_library/3rdparty/tinygl-0.4-ugfx/include -I/cygdrive/C/ugfx_studio_0.13_windows/ugfx_library/drivers/multiple/Win32 -I/cygdrive/C/ugfx_studio_0.13_windows/ugfx_library/drivers/gaudio/Win32 -DGDISP_SCREEN_WIDTH=480 -DGDISP_SCREEN_HEIGHT=272 -DGFX_USE_OS_WIN32=TRUE fakefile.c -o .build/obj/fakefile.o

.

Linker Options........

i686-pc-mingw32-gcc -m32 -Wl,--gc-sections -lgdi32 -lwinmm .build/obj/fakefile.o -o .build/preview.exe

.

Compiling gui.c

C:/ugfx_studio_0.13_windows/ugfx_library/tools/gmake_scripts/compiler_gcc.mk:242: recipe for target '.build/obj/gui.o' failed

make: *** [.build/obj/gui.o] Error 127

I know I am probably breaking a bunch of stuff you had setup already. I did a copy over so anything extra you added should still be there. 

Edited by MobileWill

Share this post


Link to post
Share on other sites

If you have installed cygwin and the required cygwin packages (listed in the wiki) then you can go to the Preferences Dialog in the studio and select the corresponding cygwin preset in the Build tab.

Yes, that looks better! Maybe we have to update the cygwin distribution shipped with the studio.

Share this post


Link to post
Share on other sites

Hi,

I'm having problem to run "Preview Generator" so I tried as suggested above but no success; may be I'm missing few details.

I would be grateful if you could share the steps to resolve the error.

Looking forward to hearing from you.

Cheers.

Share this post


Link to post
Share on other sites
55 minutes ago, smv rec said:

Hi,

I'm having problem to run "Preview Generator" so I tried as suggested above but no success; may be I'm missing few details.

I would be grateful if you could share the steps to resolve the error.

Looking forward to hearing from you.

Cheers.

Can you provide some more information like the error you are receiving?

Share this post


Link to post
Share on other sites

When I run "Preview"

Setting up environment...

Generating makefile...

Generating user colors...

Generating user styles...

Generating code...

Generating configuration...

Generating resource files...

Generating main function files...

Compiling program...

Process error: Failed to start

 

and no Information appears in "Show-Details / Hide-Details"

Share this post


Link to post
Share on other sites

Hi ,

       I have installed the new version of ugfx studio 0.13 and OS is ubuntu 14.04  having problem after clicking priview for my demo project and studio is closing.  please check the snapshot of it.

error.png

Edited by manokarthik

Share this post


Link to post
Share on other sites

We will try to fix this issue as quickly as possible. Please give us a day or two to setup an Ubuntu 14.04 LTS virtual machine for testing. We only tested on Ubuntu 15.04, Archlinux, Linux Mint and a few other Linux distributions.

Edit: We managed to track-down and fix this issue. We will most likely release 0.14 tomorrow that will contain the corresponding fix.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...