Jump to content

Online Font Converter

Recommended Posts

Is the online Font Converter working?

When using from https://ugfx.io/font-converter the browser drops through to https://fonts.ugfx.io/index.php whereupon it displays the "could not import font - bad file format" message. I am using windows font file arial.ttf and I cannot get it to work with any character filter.

I would use the built-in font converter in uGFX Studio but I want to restrict the conversion to a custom range to include the Greek Omega character and Studio won't allow a range beyond 255? Is there a way in uGFX Studio to limit the Custom Range to include just the Omega character, (U+03A9)? 

Share this post

Link to post
Share on other sites

Hi Joel,

I am still seeing the same issue, although I now see the file upload percentage in the browser lower left corner which I don't recall seeing before.

It still complains about  "could not import font - bad file format" despite trying several different ttf fonts?

Should I see some sort of confirmation that the request is valid/has been accepted, once the "Get .c File" button is pressed?  (I haven't used the Font Converter for some time until recently).

Share this post

Link to post
Share on other sites

Hi Joel,

I tried again this morning and I can confirm that there are two reasons why I have been having a problem.

The first is that the converter fails if the font file is selected directly from the Windows font folder, but works ok if the font is within some other folder. ?????

The second reason is that I was trying to obtain a large font and all font sizes over 20px fail for Arial.ttf causing the webpage to drop through to https://fonts.ugfx.io/index.php.

I also tried another font, (Candara), and font sizes >21 fail for this font. 

I used numeric only conversions to limit the file size in each case. 

Incidentally, I also found that it is necessary to refresh the browser page before attempting a second conversion request in order to get rid of the "No Entry" symbol when hovering over the "Get .C File" button.

Edited by chrisjn52

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now