Jump to content
fishermr

FreeRTOS Semaphore Create Mutex

Recommended Posts

I am using the STM32F429i-Eval1 dev kit.  Working on a home appliance that has a LCD touch panel embedded.  I am using trueStudio 9.0 as the IDE.

During gfxInit(), I have traced through the init functions to where gwin_wm.c fun gwinUpdate calls gfxSemInit.  In gfxSemInit the call to xSemaphoreCreateCounting gets stuck when limit=1 and val = 1.  When limit = 0, the functions executes.

Cannot figure out why this is happening.  Probably a setting isn't set correctly. 

Any help is appreciated. 

My project is attached.  

 

STM32F4_freertos.zip

Share this post


Link to post
Share on other sites

Thanks for the direction.  I read the suggested link many times and changed the code to match this recommendation and still no progress.  I know this issue is related to FreeRTOS.  I have tried using uGFXMain as well. but no change in behavior.    

I have a commercial license and I am good to pay for support.  Would be appreciative if I could get help with this issue  we can get on with the actual development.

Thanks.

Share this post


Link to post
Share on other sites

I would start by increasing the stack size of your intialization thread: osThreadDef(defaultTask, StartDefaultTask, osPriorityNormal, 0, 128);

128bytes might not be enough to initialize everything.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×